Приложение А.

Средства вывода чертежа на бумагу

Команды, описанные в данном приложении, обеспечивают вывод изображений на печать, а также настройку параметров печатающих устройств и режимов печати.

Ряд функций печати тесно связан с понятиями пространства модели и пространства листа, которые нуждаются в дополнительном пояснении. Главное окно системы AutoCAD 2002 имеет несколько вкладок: вкладку пространства модели (при открытии окна активизируется по умолчанию) и несколько вкладок компоновок пространства листа. Методика работы с этими вкладками видна на примере трехмерного проектирования. В пространстве модели создается трехмерная модель детали или сборочной единицы, а пространство листа служит для оформления чертежей изделия на основе видов, разрезов и сечений, автоматически получаемых с трехмерной модели. При этом возможность создания нескольких вкладок-компоновок позволяет упорядоченно разместить в одном файле несколько взаимосвязанных чертежей, например сборочный чертеж, полученный с трехмерной модели, и его деталировку. При классическом двухмерном проектировании использование компоновок пространства листа может быть оправдано при создании очень сложных изображений изделия, когда его составные части необходимо оформить в виде отдельных чертежей. В то же время подобная задача может быть легко решена и путем создания новых файлов. Поэтому использование пространства листа при двухмерном проектировании определяется, главным образом, особенностями приемов работы конкретного пользователя.

Команда PAGESETUP

Назначение:

Используется для настройки параметров печати текущего чертежа.

Вызов команды:

Командная строка: PAGESETUP

Выпадающее меню: File > PAGE SETUP

Инструментальная панель: Layouts >PAGESETUP

Команда PAGESETUP используется, как правило, при создании новой компоновки в пространстве листа. При запуске команды открывается диалоговое окно Page Setup (рис. П.1), содержащее две панели, две вкладки: Plot Device и Layout Settings, флажок и группу кнопок.

Панель Layout name содержит единственное поле ввода. В нем указывается имя компоновки пространства листа, для которого производится настройка параметров. Если команда PAGESETUP вызывается из пространства модели, поле ввода панели Layout name недоступно.

Рис. П.1. Диалоговое окно Page Setup

Панель Page setup name обеспечивает работу с именованными стилями настроек параметров печати. Панель содержит раскрывающийся список и кнопку Add.

При нажатии кнопки Add открывается диалоговое окно User Defined Page Setups (рис. П.2), которое содержит поле ввода New page setup name, поле Page setups и кнопки Rename, Delete и Import.

Рис. П.2. Диалоговое окно User Defined Page Setups

В нижней части диалогового окна Page Setup расположен флажок Display when creating a new layout, который включает или отключает режим автоматического запуска команды PAGESETUP при создании новой компоновки пространства листа.

Также внизу окна помимо стандартных кнопок OK, Cancel и Help размещена кнопка Plot, которая позволяет вывести текущую компоновку листа с текущими параметрами печати на бумагу.

Вкладка Plot Device

Вкладка Plot Device (см. рис. П. 1) позволяет назначить печатающее устройство, произвести настройку его параметров и выбрать стиль печати. Вкладка содержит две панели и одну кнопку.

Кнопка Options позволяет перейти на вкладку Plotting диалогового окна команды OPTIONS. Панель Plotter configuration определяет свойства печатающего устройства.

Вкладка General диалогового окна Plotter Configuration Editor содержит описание плоттера и его драйверов.

Рис. П.З. Диалоговое окно Plotter Configuration Editor

Вкладка Ports диалогового окна Plotter Configuration Editor содержит информацию о портах печатающего устройства.

Вкладка Device and Document Settings (см. рис. П.З) диалогового окна Plotter Configuration Editor содержит список свойств печатающего устройства и средства их редактирования. При выборе какого-либо пункта списка в средней части окна отображается панель со средствами изменения значения указанного свойства. Содержание списка свойств может несколько различаться в зависимости от конкретного типа плоттера, но обычно включает в себя:

Кнопки Import, Save As и Defailts диалогового окна Plotter Configuration Editor расположены в нижней части окна.

После окончания редактирования конфигурации печатающего устройства и нажатии кнопки ОК, система выводит диалоговое окно Changes to a Printer Configuration File (рис. П.4). Окно содержит единственное поле ввода для задания имени и места расположения создаваемого РСЗ-файла.

Рис. П.4. Диалоговое окно Changes to a Printer Configuration File

Панель Plot style table вкладки Plot Device предназначена для работы со стилями печати.

В AutoCAD 2002 предусмотрены два вида стилей печати: цветовые и именованные (стиль печати — совокупность специфических настроек и режимов печати). В цветовых стилях свойства получаемого изображения поставлены в соответствие цветам объектов. В именованных стилях, которые могут присваиваться объектам как свойства, вид получаемого изображения не зависит от цвета объектов. Какой из видов стилей используется в текущем чертеже, определяют переключатели Use color dependet plot styles и Use named plot styles вкладки Plotting диалогового окна команды OPTIONS.

Цветовые стили печати представляют собой файлы с расширением СТВ, а именованные стили — файлы с расширением STB. Именованные стили могут включать в себя несколько дочерних стилей, задающих различные режимы печати объектов. Такие дочерние стили также присваиваются объектам в качестве свойств. Для именованных стилей существует автоматически создаваемый дочерний стиль Normal, параметры которого изменить нельзя.

В системе AutoCAD пользователям предлагается несколько уже готовых стилей печати:

Кроме этого имеются несколько именованных стилей — примеров для различных областей машиностроения.

Панель Plot style table содержит раскрывающийся список и две кнопки:

При редактировании существующего стиля печати, а также на одном из шагов при создании нового стиля, система отображает диалоговое окно Plot Style Table Editor (рис. П.5), содержащее исчерпывающие средства настройки стиля печати. Окно имеет три вкладки: General, Table View и Form View.

Вкладка General содержит описание стиля печати, путь к редактируемому файлу стиля, один флажок и поле ввода.

Рис. П.5. Диалоговое окно Plot Style Table Editor

Вкладка Table View отображает свойства стилей печати в виде таблицы, в которых для цветовых стилей представлены параметры печати каждого цвета (всего 255 цветов), а для именованных - каждого существующего стиля.

Вкладка Form View отображает свойства текущего стиля печати в панели Properties, где представлен перечень изменяемых параметров в виде списка.

Параметры, задаваемые на последних двух вкладках, идентичны, поэтому рассмотрим только одну из вкладок.

Вкладка Form View (см. рис. П.5) диалогового окна Plot Style Table Editor содержит список Plot styles, панель Properties и четыре кнопки.

Кнопки Add Style, Delete Style, Edit Lineweights, Save As вкладки Form View расположены в ее нижней части.

Вкладка Layout Settings

Вкладка Layout Settings (рис. П.6) содержит средства управления выводом чертежа на бумагу. Здесь можно выбрать формат листа бумаги и его ориентацию, получить сообщение о границах области вывода для выбранного формата, выбрать или задать масштаб изображения на бумаге и определить ряд других параметров. На вкладке представлено шесть панелей.

Панель Paper size and paper units предназначена для выбора формата и единиц измерения для листа бумаги. Панель содержит два информационных поля, раскрывающийся список и два переключателя.

Рис. П.6. Вкладка Layout Settings

Панель Drawing orientation предназначена для выбора ориентации листа и содержит два переключателя и флажок.

Панель Plot area предназначена для задания границ области изображения, выводимой на печать.

Панель Plot scale предназначена для указания масштаба печатаемого изображения.

Панель Plot offset предназначена для корректировки положения области вывода на листе бумаги.

Панель Plot options предназначена для задания некоторых дополнительных параметров печати.

Команда PLOTTERMANAGER

Назначение:

Используется для установки новых устройств печати и настройки существующих печатающих устройств.

Вызов команды:

Командная строка: PLOTTERMANAGER

Выпадающее меню: File > PLOTTER MANAGER

При вызове команды открывается окно Plotters (рис. П.7) корневого каталога системы AutoCAD. На этом действие команды исчерпывается. Открыть каталог Plotters можно любым другим способом, принятым в Windows. Каталог содержит файлы конфигураций печатающих устройств (РСЗ-файлы), а также ярлык Add-A-Plotter Wizard, запускающий мастер установок новых устройств печати. Эта программа предоставляет пользователю возможность пошагового выполнения процесса установки нового печатающего устройства и практически аналогична стандартной программе установки принтера в системе Windows.

Рис. П.7. Окно каталога Plotters

При двойном щелчке мыши на значке РСЗ-файла открывается диалоговое окно Plotter Configuration Editor (см. рис. П.З), описанное выше при рассмотрении команды PAGESETUP. В этом окне можно редактировать настройки установленных печатающих устройств. Следует отметить, что редактирование в данном случае выполняется автономно от системы AutoCAD, так как выполнение команды PLOTTERMANAGER в этот момент уже завершено.

Команда STYLESMANAGER

Назначение:

Используется для редактирования существующих стилей печати и создания новых.

Вызов команды:

Командная строка: STYLESMANAGER

Выпадающее меню: File > PLOT STYLE MANAGER

При вызове команды открывается окно Plot Styles (рис. П.8) корневого каталога системы AutoCAD. На этом действие команды исчерпывается. Открыть каталог Plot Styles можно любым другим способом, принятым в Windows. Каталог содержит файлы стилей печати (СТВ- и STВ-файлы), а также ярлык Add-A-Plot Style Table Wizard, запускающий мастер создания новых стилей печати.

Рис. П.8. Окно каталога Plot Styles

При двойном щелчке мыши на значке СТВ- или STB-файла, открывается диалоговое окно Plot Style Table Editor (см. рис. П.5), описанное выше при рассмотрении команды PAGESETUP, в котором можно редактировать существующие стили печати. Так же как и в случае команды PLOTTERMANAGER, редактирование стилей печати выполняется автономно от системы AutoCAD.

Программа Add-A-Plot Style Table Wizard предоставляет возможность пользователю последовательно выбрать вид стиля, задать имя и расположение его файла,и отредактировать создаваемый стиль при помощи диалогового окна Plot Style Table Editor.

Команда PREVIEW

Назначение:

Используется для предварительного просмотра изображения перед печатью. Вызов команды:

Командная строка: PREVIEW

Выпадающее меню: File > PLOT PREVIEW

Инструментальная панель: Standard Toolbar > PLOT PREVIEW

При вызове данной команды система переходит в режим полного предварительного просмотра изображения, когда чертеж отображается на экране так же, как в последующем он будет выглядеть на бумаге (рис. П.9).

Команды контекстного меню этого режима позволяют подробно рассмотреть отдельные части изображения, выйти из режима (Exit) или завершить работу с командой, направив изображение на печать (Plot).

Рис. П.9. Окно команды PREVIEV

Команда PLOT

Назначение:

Используется для вывода изображений на печать.

Вызов команды:

Командная строка: PLOT

Экранное меню: File >PLOT

Выпадающее меню: File >PLOT

Инструментальная панель: Standard Toolbar>PLOT

В ответ на команду система открывает диалоговое окно Fast Track to Plotting Help, предлагающее пользователю предварительно познакомиться с информацией о процедуре печати. Требуется нажать кнопку Yes, если необходимо получить справку, или кнопку No, если справка не требуется. Чтобы это окно не появлялось в дальнейшем при вызове команды PLOT, следует отключить расположенный в нижней части этого окна флажок Do not show this dialog again.

Диалоговое окно Plot (рис. П. 10) обеспечивает настройку параметров печати. Окно содержит две вкладки Plot Device и Plot Settings, панели Layout name и Page setup name и кнопки Full Preview и Partial Preview. В целом диалоговое окно Plot почти идентично диалоговому окну команды PAGESETUP, но имеет некоторые отличия.

Рис. П.10. Диалоговое окно Plot

Панель Layout name содержит имя текущего пространства вывода (обычно Model) и один флажок.

Панель Page setup name обеспечивает работу с именованными стилями настроек параметров печати точно так же, как и в команде PAGESETUP.

Рис. П.11. Окно предварительного просмотра Partial Preview

Вкладка Plot Device (см. рис. П.10) позволяет назначить печатающее устройство, произвести настройку его параметров, выбрать стиль печати и задать количество копий. Вкладка содержит четыре панели: Plotter configuration, Plot style table, What to plot и Plot to file. Работа с первыми двумя панелями рассмотрена при описании команды PAGESETUP.

Панель What to plot, предназначенная для выбора режима вычерчивания компоновок листа, и панель Plot to file, обеспечивающая настройку параметров печати в файл, расположены в нижней части вкладки Plot Device. ,

Панель What to plot содержит три альтернативных переключателя и поле ввода.

Вкладка Plot Settings (рис. П. 12) содержит средства управления выводом чертежа на бумагу. Она аналогична вкладке Layout Settings диалогового окна команды PAGESETUP.

Пример получения твердой копии чертежа

Рассмотрим последовательность действий при выводе чертежа на бумагу (рис. 4.4). Предположим, что чертеж необходимо распечатать в черно-белом варианте на бумаге формата А4 при помощи принтера HP DeskJet 420, причем должен быть задан экономичный режим печати.

Для запуска процесса получения твердой копии чертежа следует ввести команду PLOT, после чего откроется одноименное диалоговое окно. Дальнейший порядок действий может быть следующим.

На вкладке Plot Device следует:

Рис. П.12. Диалоговое окно Plot Settings

Отметим, что по умолчанию в диалоговом окне Changes to a Printer Configuration File задается создание временного (только на текущий сеанс печати) файла новой конфигурации принтера.

Рис. П.13. Установка экономичного режима печати

Рис. П.14. Выбор стиля печати

Рис. П.15. Выбор формата На вкладке Plot Settings следует: